View Issue Details

IDProjectCategoryView StatusLast Update
0000104GeoSetterImage Datapublic2008-01-31 20:13
Reporterbabar Assigned ToFriedemann  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.2.4 release 
Target VersionFixed in Version2.2.5 release 
Summary0000104: XMP data are not properly synchronised from iptc
DescriptionHello, Here are 2 photos:
the original and the one edited with geosetter.
I do not know if the issue come from exiftool or geosetter, as an error comes back from exiftool (cf third attachement)
It seems that only part of the iptc comments are copied to XMP
plus all "Enter"(line jump) are replaced by"..."
Regards
Eric
TagsNo tags attached.

Activities

Friedemann

2008-01-06 15:27

administrator   ~0000220

There's only one attachment. Can you please send me the three files to support@geosetter.de?

babar

2008-01-06 15:33

reporter   ~0000221

to reproduce just open the original photo, and modify one of the iptc parameters other than the one existing. (for example add a value for "credit")
and save.
->an error appears
-> the image is modified nonetheless but the software does not know about it.
Regards

babar

2008-01-06 15:47

reporter   ~0000222

I am wondering if all that come from the newline tat are in my original iptc comments.
I noticed that the exif tool version used by geaosetter was 7.03 and found that following change for version 7.04:
-Added ability to insert a newline using "$/" in a print format string
Regards
Eric

Friedemann

2008-01-06 15:48

administrator   ~0000223

I see... the proble are the quotation marks. I'll fix it. But where do you see that line breaks will be replaced by "..."? I think ExifTool replaces line breaks with "." only for viewing.

babar

2008-01-06 15:52

reporter   ~0000224

Ok I understand, I suppose I have several line break.
Thank you very much
Regards
Eric

Friedemann

2008-01-06 21:16

administrator   ~0000225

As I said already, the problem has been caused by quotes in data text. I fixed it, but ExifTool still has a small bug for its own: Adding keywords containig quotes is possible, but it isn't possible to remove them again.

Phil Harvey (ExifTool) told me, that he'll fix it in version 7.10

babar

2008-01-27 12:40

reporter   ~0000337

Last edited: 2008-01-27 12:47

hello,
I have no more error messages but the comments field are truncated ( I suppose it would be the same for other fields such as title or special instructions,...).
I suppose this could come from the quotqion mark a gain. That is why I reopened that issue.
I attach a picture of the iptc-xmp comments in geosetter and in an other software so you can see the differences in the comments.
we can notice 2 things:
-the first quotation mark before -- ocean -- has disappeared
-the rest of the comment after -- ocean -- has also disappeared.
Best regards
Eric
PS: you should be able to use the previously uploaded original photo , it is the one I used to check that problem.

Friedemann

2008-01-27 14:48

administrator   ~0000338

Unfortunately I can't reproduce it here. In the attachement "babar_comment.jpg" you can see that I inserted "xxxx" into the comment, saved it, and still the quotation marks exist.

Will they be deleted after saving with GeoSetter, or don't you see them already before saving? If you see them first, and then after saving the're deleted, please send me a screenshot of the save report. because I can't reproduce it with the image attached already, it would perhaps help if you can send me the image in which you don't see the quotation marks anymore.

Friedemann

2008-01-27 14:50

administrator   ~0000339

Please send me also a screenshot of your JPEG-Settings in GeoSetter ("R├Ęglages | File Options", select first entry).

babar

2008-01-27 16:41

reporter   ~0000340

Hello,
Which report do you mean?
I tried to reproduce it with the photo I uploaded last time and could not but I do reproduce it with the photos I have. I suppose it comes from what last version of geosetter did change.
It looks like geosetter is showing iptc data while Itag (other software) display the xmp data, hence the difference. So I suppose we can close that bug. Sorry for reopening it.
I will however upload you a photo where you can check it and my settings.
I suppose it could be interesting for synchronisation issues?

Friedemann

2008-01-28 19:19

administrator   ~0000344

GeoSetter loads both, IPTC and XMP data. If a data field is availabele in both, then GeoSetter takes it from XMP. In "Nigeria lagos 03.JPG" the IPTC data contains the quotation marks but XMP data doesn't. Maybe you're right that this has been caused by the last version of GeoSetter before fixing the quotation mark problem, I'm sorry. Are you familiar with the command line? Then it would be possible to copy the correct IPTC description field to its corresponding XMP field.

babar

2008-01-28 23:59

reporter   ~0000348

Hi
Great do not worry for my photos, I have only used geosetter for testing purposes so far and not for production yet (I lost once all my exif/iptc tags on 5000 photo with adobe, since then I am very cautious before using a new software :) )
However this problem may have unveiled another problem
Open the last photo that I uploaded
change any of the xmp data except the comments
-> you will see then that IPTC comments are updated with the xmp field value.
I would expect only the field that I changed to be updated.
Is there a reason for updating the other fields as well. Isn't it also solwing done things?

Issue History

Date Modified Username Field Change
2008-01-06 15:23 babar New Issue
2008-01-06 15:23 babar File Added: Nigeria lagos 04.JPG
2008-01-06 15:25 Friedemann Status new => assigned
2008-01-06 15:25 Friedemann Assigned To => Friedemann
2008-01-06 15:26 babar File Added: Nigeria lagos 04 Original.JPG
2008-01-06 15:27 Friedemann Note Added: 0000220
2008-01-06 15:27 Friedemann Status assigned => feedback
2008-01-06 15:29 babar File Added: error.png
2008-01-06 15:33 babar Note Added: 0000221
2008-01-06 15:47 babar Note Added: 0000222
2008-01-06 15:48 Friedemann Note Added: 0000223
2008-01-06 15:52 babar Note Added: 0000224
2008-01-06 21:16 Friedemann Status feedback => resolved
2008-01-06 21:16 Friedemann Fixed in Version => 2.2.5
2008-01-06 21:16 Friedemann Resolution open => fixed
2008-01-06 21:16 Friedemann Note Added: 0000225
2008-01-27 12:40 babar Status resolved => feedback
2008-01-27 12:40 babar Resolution fixed => reopened
2008-01-27 12:40 babar Note Added: 0000337
2008-01-27 12:40 babar File Added: iptc-xmp-comments.png
2008-01-27 12:43 babar Note Edited: 0000337
2008-01-27 12:47 babar Note Edited: 0000337
2008-01-27 12:47 babar Note Edited: 0000337
2008-01-27 14:41 Friedemann File Added: babar_comment.jpg
2008-01-27 14:48 Friedemann Note Added: 0000338
2008-01-27 14:50 Friedemann Note Added: 0000339
2008-01-27 16:41 babar Note Added: 0000340
2008-01-27 16:42 babar File Added: jpeg-options.png
2008-01-27 16:43 babar File Added: Nigeria lagos 03.JPG
2008-01-28 19:19 Friedemann Note Added: 0000344
2008-01-28 23:59 babar Note Added: 0000348
2008-01-31 20:13 Friedemann Status feedback => resolved
2008-01-31 20:13 Friedemann Resolution reopened => fixed