View Issue Details

IDProjectCategoryView StatusLast Update
0002019GeoSetterUser Interfacepublic2019-02-01 16:48
Reporterabr01 Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status newResolutionopen 
Product Version3.5 
Target VersionFixed in Version 
Summary0002019: Geosetter friert ein, ist nicht mehr nutzbar
DescriptionHallo Herr Schmidt,


seit heute funktioniert die Version 3.5 von Geosetter nicht mehr. Das Programm lädt keine Karte mehr, und friert dabei ein. Auch die Bildervorschau links friert mitten beim Aufbau ein.
Vielleicht hat Google erneut etwas geändert, denn bisher kam nur eine Fehlermeldung von Google, die man wegklicken konnte. Geosetter funktionierte trotzdem.

Nun kommt beim Schließen folgende Meldung:

Managing metadata (EXIT/IPTC/XMP) of image files reagiert nicht





Steps To ReproduceGeosetter starten.
TagsNo tags attached.

Activities

heiko

2019-01-18 16:34

developer   ~0003639

Funktioniert GeoSetter nach einem Neustart des Rechners wieder? Bei mir läuft die Version 3.5 problemlos.

abr01

2019-01-18 17:10

reporter   ~0003640

Nein, den Rechner hatte ich mehrfach neugestartet, dasselbe Problem leider.

abr01

2019-01-18 18:28

reporter   ~0003641

UPDATE: wenn ich Geosetter im Administratormodus starte, komme ich ein Stück weiter. Allerdings wird die Karte nicht vollständig angezeigt, und es ist etwas von "Developer Mode" als Muster
auf der Karte zu sehen. Danach friert es ein. Muß ich eine bestimmte neue Geo-URL angeben? Das hatte sich ja zwischendurch mehrfach geändert.

Liest eigentlich der Entwickler hier mit? Ich hätte doch gerne ein paar mehr Vorschläge, nachdem auch eine Neuinstallation nichts gebracht hatte. Oder wenigstens einen Vorschlag auf
ein alternatives Programm. Es ist für mich wichtig, Geodaten in Bildern zu taggen. Danke schonmal für die Mühe!

heiko

2019-01-18 20:47

developer   ~0003642

Wurde vor einer Neuinstallation von GeoSetter das Verzeichnis %AppData%\GeoSetter auch gelöscht?

Eine Alternative um Bilder zu taggen ist z.B. Lightroom.

abr01

2019-01-18 20:50

reporter   ~0003643

Nein, das hatte ich noch nicht probiert. Ich hab eigentlich auch nicht vor unzusteigen, sondern suche nur etwas zur Überbrückung, bis Geosetter wieder bei mir läuft. Lightroom habe ich hier, aber nur Version 5, wo ich nicht wüsste, ob sie das auch kann.
Danke für den Hinweis!

heiko

2019-01-18 21:01

developer   ~0003644

In Version 5 von Lightroom wurde die Karte abgeschalten, also ist das wohl keine Alternative.

Wurde denn an dem Rechner etwas geändert? Scheinbar hat GeoSetter ja schonmal funktioniert. Was für ein Betriebssystem ist denn installiert? Falls Win 10, wurde evtl. das Oktober Update eingespielt (Build 1809), das wurde die Tage von MS auf breiterer Ebene freigegeben.

Die Meldung "Developer Mode" in der Karte hängt übrigens mit den Einstellungen zur Bezahlmethode bei Google, die Friedemann Schmidt hinterlegt hat, zusammen.

abr01

2019-01-18 21:12

reporter   ~0003645

Nein, programmetechnisch wüsste ich nichts Neues. Aber eins fiel mir neulich shcon einmal auf. Manchmal, wenn ich Strg-G drückte, um alle Bilder in die Karte zu laden, blieb oft das "ok" Fenster ausgegraut. Da musste ich manchmal mehr als ein halbes Dutzend mal das Programm
neustarten, bin die Schaltfläche benutzbar war. Installiert ist Windows 10, Version 1803. Da hat sich also nicht geändert. Das Programm läuft übrigens so lange, bis ich auf den Kartenmode umschalten will, der ja die eigentliche Arbeitsfläche ist. Dann stürzt es ab.

Nur fürs Protokoll, die Karten-URL hier lautet: http://map.geosetter.de/v3/map_google.html

Ist das korrekt so?

abr01

2019-01-18 21:17

reporter   ~0003646

Was natürlich zwischendurch neu war, das sind wohl kb-Patches von Microsoft. Könnten die das nicht verursacht haben? Wobei ich sowas eigentlich noch nie hatte.

heiko

2019-01-18 21:35

developer   ~0003647

Last edited: 2019-01-18 21:35

View 2 revisions

ich habe hier Win 10 Build 1803 mit den aktuellsten Patches von MS, bei mir läuft wie gesagt alles problemlos. Was schon vorgekommen ist, dass bestimmte Bilder zu einem Absturz geführt haben.

abr01

2019-01-18 21:48

reporter   ~0003648

Also, ich habe schon ältere Sessions getestet, gleiches Ergebnis, zumal ich mit dieser Kamera schon viele Bilder in geosetter bearbeitet habe. Sehr seltsam.

gehav

2019-01-19 08:45

reporter   ~0003649

Ich habe leider das gleiche (oder zumindest ein sehr ähnliches) Problem wie abr01 - seit ein paar Tagen friert Geosetter immer beim Start ein. Dann erscheint die Karte nach langer Zeit doch, aber Geosetter friert immer ein, wenn man die Karte bedienen möchte (zoomen). Das Programm ist damit leider plötzlich unbenutzbar geworden. Das passiert auf 2 PCs, sowohl in der portablen als auch in der installierten Variante. Es wird wohl an Windows Updates liegen, denn auf einem älteren Notebook mit Win10, das schon 2 Jahre lang keine Updates installiert hat, läuft Geosetter noch problemlos.

abr01

2019-01-19 14:56

reporter   ~0003650

Danke für die (wahrscheinliche) Bestätigung.

Franklin2K

2019-01-19 17:41

reporter   ~0003651

Ich habe das gleiche Problem, bis vor ein paar Tagen lief GeoSetter prima (mit eigenem API Key hinterlegt). Seit 3-4 Tagen jedoch hängt das Programm beim Start und vielen Aktionen.
Ich bin auf Windows 18 1809 inkl. aller Updates. Ich vermute auch, dass hier ein Update das Problem, verursacht.

abr01

2019-01-22 14:30

reporter   ~0003657

Eine Frage mal an die Entwickler, wird eigentlich schon an einer Problemlösung gearbeitet?

Thomas

2019-01-22 18:57

reporter   ~0003658

Ich hab' seit ein paar Tagen, genau das gleiche Problem, ebenfalls Win10, ebenfalls keine Änderungen am PC außer ggfs. WinUpdates.

Beim Starten von Geosetter kommt, wenn man lange genug wartet, eine Fehlermeldung, dass ein Skript sehr lange läuft. Wenn man dann anklickt, dass man das Skript abbrechen will, "funktioniert" Geosetter, aber ohne Karte (weder Google noch OSM).
Ich kann dann z.B. einen Location-Favoriten auswählen und dessen Daten Bildern zuweisen - halt "blind".

gehav

2019-01-23 11:03

reporter   ~0003659

@abr01: Geosetter wurde von einem Entwickler als Hobby in seiner Freizeit geschrieben. In den letzten Jahren hat sich kaum mehr was getan und ich fürchte daher, dass eine Lösung lange dauern könnte... Siehe auch: https://www.geosetter.de/2018/05/10/new-website-new-geosetter-de/

EkMaKro

2019-01-23 12:49

reporter   ~0003660

Seit einigen Tagen habe ich das gleiche Problem.
Geosetter 3,5 Windows 7 x64

Das Problem ist unabhängig vom gewählten Kartentyp.
Der Taskmanager zeigt, dass Geosetter die CPU dann dauerhaft stark beansprucht (allerdings ohne das ersichtlich was passiert).
Seltsamerweise hat heute das Programm ein paar mal zwischendurch wieder etwas schneller reagiert (aber immer noch deutlich verlangsamt), um dann wieder in die "Erstarrung" zu verfallen.
So ist das Programm leider nicht nutzbar !

abr01

2019-01-23 13:40

reporter   ~0003661

Das ist dann ja ganz schlecht. Was ich nicht verstehen kann, daß es offenbar so gut wie keine ähnlichen Programme gibt, auf die man ausweichen könnte. Wie kann das überhaupt angehen?

gehav

2019-01-23 14:42

reporter   ~0003662

Ich habe einen Workaround gefunden, der zumindest bei mir momentan funktioniert. Es ist keine schöne und saubere Lösung, aber ich komme damit zurecht. Wie EkMaKro schon richtig geschrieben hat, wird ja die CPU offenbar von der Kartenansicht völlig ausgelastet. Die "Lösung" für mich war also das Fenster der Kartenansicht so weit zu verkleinern, bis meine CPU nicht mehr zu stark ausgelastet war und die Navigation wieder halbwegs flüssig funktioniert hat. Wie gesagt, nicht optimal, aber ich kann mit Geosetter zumindest wieder arbeiten. Anleitung: ich habe die Kartenansicht abgedockt (kleiner Pfeil rechts oben in der Kartenansicht), dann kann man die Karte unabhängig vom restlichen Programm vergrößern oder verkleinern. Ich habe soweit verkleinert, bis alles flüssig funktioniert hat und dann wieder soweit vergrößert, bis es zu Ruckeln begonnen hat. Ich schätze, dass die Kartenansicht momentan nur mehr ca. 800x400 Pixel hat. Hoffe, diese Information kann jemandem helfen!

lamalate

2019-01-23 17:03

reporter   ~0003663

Même problème depuis la dernière mise à jour d'exiftool aujourd'hui.

lamalate

2019-01-23 17:07

reporter   ~0003664

J'ai remis la version précédente d'exiftool, soit la 11.25 depuis geosetter/tools.exiftool.bak et cela refonctionne normalement
Ich habe die vorherige Version von exiftool (11.25) von geosetter / tools.exiftool.bak geliefert und es funktioniert wieder

Franklin2K

2019-01-23 20:46

reporter   ~0003665

Bei mir tritt das Problem mit ExifTool 11.25 und 11.26 auf, ich glaube daher nicht, dass dies die Ursache ist...

abr01

2019-01-25 20:51

reporter   ~0003669

Gehav, guter Tipp! Auch wenn ich es etwas anders machen musste, da beim Klick auf die Registerkarte "Karte" der Absturz das Abkoppeln verunmöglichte. Ich habe das gesamte Programm daher stark verkleinert, dann geht es halbwegs (es kommen Fehlermeldungen bezüglich der karte selbst, von wegen Entwicklermodus, oder so).

Gibt es denn seitens der Entwickler hier schon Pläne, das soweit zu reparieren?

WilfriedB

2019-01-28 14:26

reporter   ~0003686

Danke gehav, der Tip scheint zu funktionieren!

Das Problem wurde hier inzwischen schon mehrfach gemeldet. In einem Thread wurde der Verdacht geäußert, es könne mit einem Windows Update (KB4023057?) zusammen hängen. Zeitlich könnte das bei mir auch zutreffen. Das letzte Windows Update war bei mir am 19.1. Seit wann ich die Probleme mit GeoSetter habe, kann ich allerdings nicht ganz genau sagen.

Franklin2K

2019-01-29 10:10

reporter   ~0003689

Der Tip funktioniert, Danke! Aber schön ist das natürlich nicht. Schade dass Friedeman sich hier nicht melden

Thomas

2019-01-31 21:28

reporter   ~0003690

... und heute funktioniert plötzlich wieder alles praktisch wie früher (mit OSM) - keine Idee, wieso ...

WilfriedB

2019-01-31 21:40

reporter   ~0003691

Stimmt! Auch das Google Satelliten Bild öffnete bei mir gerade sofort. Hoffentlich bleibt das so.

Franklin2K

2019-02-01 16:48

reporter   ~0003692

Tatsache, es klappt alles wieder wie vorher. Jetzt wäre natürlich interessant, was die Ursache des Problems war.

Franklin2K

2019-02-01 16:48

reporter   ~0003693

Tatsache, es klappt alles wieder wie vorher. Jetzt wäre natürlich interessant, was die Ursache des Problems war.

Issue History

Date Modified Username Field Change
2019-01-17 17:52 abr01 New Issue
2019-01-18 16:34 heiko Note Added: 0003639
2019-01-18 17:10 abr01 Note Added: 0003640
2019-01-18 18:28 abr01 Note Added: 0003641
2019-01-18 20:47 heiko Note Added: 0003642
2019-01-18 20:50 abr01 Note Added: 0003643
2019-01-18 21:01 heiko Note Added: 0003644
2019-01-18 21:12 abr01 Note Added: 0003645
2019-01-18 21:17 abr01 Note Added: 0003646
2019-01-18 21:35 heiko Note Added: 0003647
2019-01-18 21:35 heiko Note Edited: 0003647 View Revisions
2019-01-18 21:48 abr01 Note Added: 0003648
2019-01-19 08:45 gehav Note Added: 0003649
2019-01-19 14:56 abr01 Note Added: 0003650
2019-01-19 17:41 Franklin2K Note Added: 0003651
2019-01-22 14:30 abr01 Note Added: 0003657
2019-01-22 18:57 Thomas Note Added: 0003658
2019-01-23 11:03 gehav Note Added: 0003659
2019-01-23 12:49 EkMaKro Note Added: 0003660
2019-01-23 13:40 abr01 Note Added: 0003661
2019-01-23 14:42 gehav Note Added: 0003662
2019-01-23 17:03 lamalate Note Added: 0003663
2019-01-23 17:07 lamalate Note Added: 0003664
2019-01-23 20:46 Franklin2K Note Added: 0003665
2019-01-25 20:51 abr01 Note Added: 0003669
2019-01-28 14:26 WilfriedB Note Added: 0003686
2019-01-29 10:10 Franklin2K Note Added: 0003689
2019-01-31 21:28 Thomas Note Added: 0003690
2019-01-31 21:40 WilfriedB Note Added: 0003691
2019-02-01 16:48 Franklin2K Note Added: 0003692
2019-02-01 16:48 Franklin2K Note Added: 0003693